Desenvolvimento NFS-e
Desenvolvimento NFS-e

Site destinado a desenvolvedores de softwares na integração com a NFS-e.
 
InícioInício  CalendárioCalendário  FAQFAQ  BuscarBuscar  GruposGrupos  Registrar-seRegistrar-se  Conectar-se  

Compartilhe | 
 

 Uso de acento invalidando XML

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
egon_h



Mensagens : 6
Data de inscrição : 29/04/2014

MensagemAssunto: Uso de acento invalidando XML   Qui Ago 14, 2014 3:39 pm

Prezados,

Estou fazendo testes com a prefeitura de Santos, e quando gero algum tag com acentuação, por exemplo a discriminação do serviço, o web service me retorna E300 - Erro ao converter documento em XML.

Ao enviar sem acentos a nota é processada corretamente. Já verifiquei que o XML está codificado como UTF-8.

Procede a informação de que os webservices não aceitam acentos e eu devo remove-los antes de enviar a solicitação?

Obrigado!
Voltar ao Topo Ir em baixo
Vinicius Silveira ADM
Admin
avatar

Mensagens : 441
Data de inscrição : 23/02/2012
Localização : São Paulo

MensagemAssunto: Re: Uso de acento invalidando XML   Sex Ago 15, 2014 12:55 pm

Egon,
Você pode informar os acentos normalmente, mas é importante que a codificação do 
arquivo esteja como UTF-8, não basta esta codificação estar descrita no cabeçalho do arquivo XML.

Você pode utilizar tambem o atributo CDATA na tag de descriminação dos serviços onde provavelmente estes acentos se encontram.
Voltar ao Topo Ir em baixo
http://SuporteNFS-e.forumeiros.com
 
Uso de acento invalidando XML
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Problema com acentos e caracteres especiais em páginas html
» aceitar ç e acentos na pagina html
» Alguém tem as respostas do curso livre Ed Língua Portuguesa 1 - Lista 2
» Estudo dirigido de língua portuguesa 6º semestre

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Desenvolvimento NFS-e  :: Arquivo XML-
Ir para: